Автор Тема: Проблема с аудио (при подключении наушников не отключаются динамики) [РЕШЕНО]  (Прочитано 1665 раз)

Оффлайн MindGames

  • Новичок
  • *
  • Сообщений: 20
Всем привет!
Для начала представлюсь (ибо, я тут новенький) :) (все остальное убрал под спойлер, ибо, к теме прямого отношения не имеет)
Спойлер
Зовут меня Максим. Мне 33 года, живу в Краснодаре, занимаюсь телекоммуникациями.
Из чего следует, что моя жизнь тесно связана с Линукс (на большинстве телеком устройств операционная система базируется на Линукс либо друхих *nix).
Я достаточно активно использую Линукс, верней, серверные его версии, работаю в консоли, либо в HTML интерфейсах.
В свое время я активно пользовался Линукс и на десктопе. К слову, на ноутбуке у меня до сих пор сохранился установленный Линукс Ubuntu 10.04, а точнее - его сборка от Integra-L -  Искра. Эх... золотое время дистрибутивов тогда было.. Искра, Синяя птица, Росинка и множество других достойных сборок от наших соотечественников. Да и сама голая Убунта была в общем-то, вполне работоспособна.
Но потом я купил новый стационарный комп, захотел поиграть в какую-то новую вышедшую тогда игру, под линукс она не шла и я поставил Виндовс второй системой. А потом, когда появилась Unity, и вовсе снес Линукс на стационарном компе, оставил только на ноутбуке.
Так вот, сейчас я захотел снова вернуться на Линукс в качестве основной системы. К Юнити я так и не смог привыкнуть, к сожалению.. Начал перебирать кучу дистрибутивов...
Вот, к примеру, листинг директории с дистрибутивами, которые я перепробовал (для того, чтобы оценить масштабы развернутой деятельности :) ):
Спойлер
└─ $ ▶ ls 'Linux distr'/
Alv_Dive_into_Salix.pdf.zip
BlackOpal64.iso
deepin 15 1 amd64 iso [Burnbit].torrent
DiamondIIB64.iso
elementaryos-0.3.2-stable-amd64.20151209.iso
Fedora-Live-Workstation-x86_64-23-10.iso
FW_LM16_32X.iso
Haze_OS_Cheesecake_6.0.1_64_1436973993.iso
kali-linux-2016.1-amd64
KNOPPIX_V7.4.0DVD-2014-08-01-EN.iso
Linux4games-rel22.0.23-Mint-x64-RU.iso
linux mint 17.1 mate by enriki x86.iso
linuxmint-17.3-cinnamon-64bit.iso
linuxmint-17.3-kde-64bit.iso
linuxmint-17.3-mate-64bit.iso
Matuntu-T64-M182-new.iso
Matuntu-TW64-M112.iso
[NNM-Club.ru]_Snowlinux-2-Cinnamon.torrent
[NNM-Club.ru]_Snowlinux-4.0-Frosty.torrent
pclinuxos64-kde-fullmonty-2014.12.iso
rufus
Sapphire (1).iso
Sapphire.iso
sinclairos-yosemite-amd64-beta2-install-in-english.iso
Snowlinux-4.0-Frosty
solydk_8_64_201601.iso
tanglu-dasyatis-alpha-gnome-live-amd64.hybrid.iso
ubuntu-15.10-desktop-amd64.iso
ubuntu-gamepack-14.04-amd64.iso
ubuntu-gnome-15.10-desktop-amd64.iso
ubuntu-mate-15.10-desktop-amd64.iso
ubuntu-pack-15.04-mate-amd64.iso
ultimate-edition-4.2-x64-lite.iso
ultimate-edition-4.3-x64.iso
ultimate-edition-4.5-x64.iso
ultimate-edition-5.0-x64-alpha.iso
vinux-5.0-amd64.iso
Voyager-X2-14.04.05-amd64.iso
Voyager-X2-HD-amd64.iso
xenial-desktop-amd64.iso.torrent
zorin-os-10-core-64.iso
В общем, потратив около двух недель времени, и порядком изнасиловав свой HDD :), я остановился на вариантах: Убунту Мате, Убунту (с Юнити), и Матунту. 
Убунту Мейт Мате (mate - испанское слово) прожила у меня на диске примерно неделю. В целом, все хорошо, но была куча мелких недочетов, в том числе и сабжевый. В итоге, сравнив еще раз эти три дистрибутива, понял, что мне больше всего нравится именно Матунту. Хочу перейти на него. И поэтому, решил систему основательно допиливать под себя. Тут в общем, все идеально, но есть пара моментов, которые я не знаю, как побороть. Это первая тема. Будет еще несколько тем - отдельная по каждой проблеме. В этой теме я проверю, насколько живое тут сообщество и насколько активно отвечает. Тогда буду создавать другие темы :)
Ну, а теперь, перейдем к делу.
Проблема: при подключении наушников к фронтальным разъемам, звук играет в наушниках и продолжает играть в колонках. В Винде при подключении наушников, звук в колонках глушится. Мало того, в Винде можно сделать так, чтобы в наушниках и в колонках были разные источники звуков. Дабы не раздражать людей фразами "а в Винде это работает", я скажу, что на моем ноутбуке с установленной Искрой (Убунта 10.04) при подключении наушников, колонки перестают работать и звук подается только в наушники. То есть, и в Линукс дистрибутивах это работало по крайней мере, раньше.
Проблему удается решить частично, если запустить alsamixer и в нем регулятор Front опустить на минимум. Но тоже самое я могу сделать с регулятором на колонках. Я же хочу, чтобы это было автоматически, Думал, что проблема с pulseaudio. Но, судя по всему, на убунте 10.04 тоже был Пульсаудио. То есть, выпиливать пульсаудио - не решение.
Пробовал скачать и установить драйвера Риалтек для своей аудиокарты, но установка зафейлилась на make.
Вот информация о моей звуковой карте:
звуковая карта
└─ $ ▶ lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
01:00.1 Audio device: NVIDIA Corporation GF114 HDMI Audio Controller (rev a1)

и о системе, в целом:
информация о системе
System:    Host: vita Kernel: 4.2.0-21-generic x86_64 (64 bit gcc: 4.8.2)
           Desktop: MATE 1.12.0 (Gtk 3.10.8-0ubuntu1.6) Distro: Ubuntu 14.04 trusty
Machine:   Mobo: ASUSTeK model: P8P67 v: Rev 1.xx serial: MT7014K16700010
           Bios: American Megatrends v: 1503 date: 03/10/2011
CPU:       Quad core Intel Core i5-2310 (-MCP-) cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 23278
           clock speeds: max: 3200 MHz 1: 1691 MHz 2: 1692 MHz 3: 1618 MHz 4: 1638 MHz
Memory:    Array-1 capacity: 32 GB devices: 4 EC: None
           Device-1: DIMM0 size: 2 GB speed: 1333 MHz type: DDR3 part: CMX4GX3M2A1600C9
           Device-2: DIMM1 size: 2 GB speed: 1333 MHz type: DDR3 part: 99U5458-001.A00LF
           Device-3: DIMM2 size: 2 GB speed: 1333 MHz type: DDR3 part: CMX4GX3M2A1600C9
           Device-4: DIMM3 size: 2 GB speed: 1333 MHz type: DDR3 part: 99U5458-001.A00LF
Graphics:  Card: NVIDIA GF114 [GeForce GTX 560 Ti] bus-ID: 01:00.0
           Display Server: X.org 1.17.1 drivers: nouveau (unloaded: fbdev,vesa)
           tty size: 211x55 Advanced Data: N/A for root
Audio:     Card-1 NVIDIA GF114 HDMI Audio Controller driver: snd_hda_intel bus-ID: 01:00.1
           Card-2 Intel 6 Series/C200 Series Family High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-3 eMPIA driver: USB Audio usb-ID: 006-006
           Sound: Advanced Linux Sound Architecture v: k4.2.0-21-generic
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: d000 bus-ID: 07:00.0
           IF: eth0 state: up speed: 1000 Mbps duplex: full mac: f4:6d:04:9c:90:2e
Drives:    HDD Total Size: 5261.1GB (33.0% used) ID-1: /dev/sda model: SanDisk_SDSSDHP2 size: 256.1GB temp: 30C
           ID-2: /dev/sdb model: WDC_WD1002FAEX size: 1000.2GB temp: 33C
           ID-3: /dev/sdc model: WDC_WD20EZRX size: 2000.4GB temp: 29C
           ID-4: /dev/sdd model: WDC_WD20EARX size: 2000.4GB temp: 29C
           ID-5: USB /dev/sde model: Flash_Disk size: 4.0GB temp: 0C
           Optical: /dev/sr0 model: N/A rev: N/A dev-links: cdrom
Partition: ID-1: / size: 3.9G used: 101M (3%) fs: overlay dev: /dev/cow label: N/A uuid: N/A
           ID-2: swap-1 size: 9.72GB used: 0.00GB (0%) fs: swap dev: /dev/sdb6
           label: N/A uuid: 13787422-9c3d-4ac4-a3c9-7b4e0d38fdaf
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   None detected - is lm-sensors installed and configured?
Info:      Processes: 205 Uptime: 59 min Memory: 733.8/7961.5MB Init: Upstart runlevel: 2 Gcc sys: 4.8.4
           Client: Shell (sudo) inxi: 2.2.28

Да, я сейчас пишу с живого режима. Т.к. пока не решу проблему со звуком, не вижу смысла устанавливать систему на жесткий диск.
« Последнее редактирование: 22 Февраля 2016, 14:56:57 от vita »

Оффлайн MindGames

  • Новичок
  • *
  • Сообщений: 20
Всем привет!
Кажется, проблему решил. Переключил в биос настройку для встроенной аудиокарты. Был выставлен режим AC97, поставил режим HD - звук стал автоматически переключаться.
Кто скажет, в чем прикол и почему так?
Чую, сейчас при перезагрузке в видновс, будет обратная проблема :)
« Последнее редактирование: 24 Февраля 2016, 11:50:10 от vita »

Оффлайн ivm

  • Ветеран
  • *****
  • Сообщений: 2250
Кажется, проблему решил. Переключил в биос настройку для встроенной аудиокарты. Был выставлен режим AC97, поставил режим HD - звук стал автоматически переключаться.
Кто скажет, в чем прикол и почему так?
Чую, сейчас при перезагрузке в видновс, будет обратная проблема :)
У Вас в выводе inxi три аудиокарты. Для просмотра информации об аудиокартах лучше пользоваться командой: inxi -Aпотому что карты могут быть и USB и PCI и PCIe.
Проблемы с переключением звука на наушники видел в 2009 году и с тех пор больше не встречал ни на одном дистрибутиве.
Что непонятно спрашиваем, если всё понятно - пользуемся.
Что бы ни случилось, всё будет хорошо!

Оффлайн MindGames

  • Новичок
  • *
  • Сообщений: 20
max@DigitalHaos:~$ inxi -A
Audio:     Card-1 NVIDIA GF114 HDMI Audio Controller driver: snd_hda_intel
           Card-2 Intel 6 Series/C200 Series Family High Definition Audio Controller
           driver: snd_hda_intel
           Card-3 eMPIA driver: USB Audio
           Sound: Advanced Linux Sound Architecture v: k4.4.0-7-generic


Вывод такой же, конкретно по аудио.
Три устройства определяет потому, что 1 это аудиокарта в мониторе (в мониторе встроенные колонки, сам монитор подключен по HDMI)
2 аудиокарта - это встроенная в материнскую плату
3 аудиоустройство он определяет в подключенном по USB внешнем DVD резаке. он имеет просто аудио-видео входы на борту для прямой записи на DVD c видеокассеты.

Проблему я решил, просто я думал, может быть, кто-то сможет подсказать, с чем связано такое поведение (переключил режим работы аудиокарты в биос)?
Ну а вообще, тему можно пометить как решенную (если есть такая опция). Проблема решается переключением типа режима работы аудиокарты с AC97 на HD в БИОСе.