Автор Тема: Двухполосный адаптер Wi-Fi c811 Realtek Semiconductor  (Прочитано 103 раз)

Оффлайн vita

  • Глобальный модератор
  • Ветеран
  • *****
  • Сообщений: 3132
  • Да будет свет!
Приобрела на AliExpress двухполосный (Dual Band) адаптер Wi-Fi 600 Мбит/с стандарта AC, покрывающий два диапазона: 2,4 и 5 ГГц на чипе c811 Realtek Semiconductor.
В Matuntu-B64 указанный адаптер не определяется без установки драйвера. Проверила его в списке устройств:
lsusb | grep Realtek
Цитата: вывод
Bus 005 Device 004: ID 0bda:c811 Realtek Semiconductor Corp.
На упаковке и на прилагаемом CD диске указана поддержка Linux. На деле драйвер с диска не установился.
Помощь в установке драйвера найдена на англоязычном форуме Ubuntu, на котором по ссылке на GitHub предлагается загрузить архив rtl8821CU-master.zip.
Следуя рекомендациям, распаковала архив.
Установила пакеты для компиляции модуля: sudo apt install linux-headers-generic build-essential gitДанная команда рассчитана на создание модуля для ядра 4.15.0-х Ubuntu 18.04 LTS.

Для компиляции модуля в распакованной папке открыла терминал и выполнила две команды: sudo make sudo make install
Сначала установила модуль в системе с ядром 4.15.0-х. Затем повторила установку модуля в Matuntu-B64 с ядром 4.18.0-15 (после установки модуля удалила ненужные пакеты ядра 4.15.0-х). В обоих случаях модуль скомпилировался для соответствующих ядер и адаптер работает с драйвером rtl8821cu.

Вставила адаптер в USB порт, он обнаружился и увидел большое количество двухполосных сетей Wi-Fi.
Сравнила соединения Dual Band. В диапазоне N (2,4 ГГц) - скорость соединения 72 Мб/с , а в диапазоне AC (5 ГГц) - 390 Мб/с, т.е. превышает более, чем в 5 раз!
Делай с нами, делай как мы, делай лучше нас!

Оффлайн vita

  • Глобальный модератор
  • Ветеран
  • *****
  • Сообщений: 3132
  • Да будет свет!
Re: Двухполосный адаптер Wi-Fi c811 Realtek Semiconductor
« Ответ #1 : 15 Февраля 2019, 22:25:53 »
Проверила перспективу поддержки сабжевого устройства изложенным методом в системе на основе Ubuntu 19.04 (Disco Dingo) с ядром 4.19.0-13.
Упростила первую команду из начального сообщения темы, исключив установку пакета linux-headers-generic:
sudo apt install build-essential git Затем выполнила все действия по тексту.
Адаптер Dual Band работает и c ядром 4.19  :)

Делай с нами, делай как мы, делай лучше нас!